Monitoring - Updates Deployed
Incident Report for PostNord API Status Page
Postmortem

What was the issue?
Not possible to search nearest service points by a number postal codes in Finland and Norway

When did the issue start and end?
2024-09-13 - 2024-09-16

What caused the issue?
Missing postal codes and/or coordinates on postal codes.

For postal codes to be searchable in Production Point Service(PPS) the need to have a center coordinate. PPS is loading its postal codes from PCM (Postal Code Master) and will skip postal codes that is missing coordinates. In the file provided from PAM(Party Address Master) to PCM a large number of Finnish and some Norwegian postal codes is missing or/the are missing coordinates.

So when PCM was update with new postal codes last week it resulted in that the postal codes was no longer searchable in PPS.

What was done to resolve the issue?
The postal codes missing/the missing coordinates was manually added in PCM and PPS was reloaded. Resulting in that the postal codes is searchable again.

Posted Sep 18, 2024 - 09:39 UTC

Resolved
Issue is resolved - status as normal
Posted Sep 17, 2024 - 07:35 UTC
Monitoring
We are currently awaiting confirmation on the recent updates. We'll provide further details as soon as we receive confirmation.
Posted Sep 17, 2024 - 06:26 UTC
Identified
Sweco team is working on addressing the issue and will provide updates soon.
Posted Sep 16, 2024 - 13:27 UTC
This incident affected: Location (Service Points V5).